Monday, January 05, 2009

Greasemonkey Release 0.8.20090123.1

In preparation for Firefox 3.1, we're releasing a new version of Greasemonkey, marked as compatible with Firefox 3.1b2, along with additional changes and fixes:
  • Added translations: ar-SA, bn-IN, hu-HU, id-ID, ro-RO, sr-RS, vi-VN.
  • Fix for ticket #111 (anomalous separators in the monkey menu).
  • Add GM_deleteValue() and GM_listValues() APIs (#38).
  • Restore the anonymous function wrapper around scripts, and thus the same behavior as versions prior to 0.8 (by default, removable with the @unwrap metadata imperative, #108).
  • Improved interaction with the Firebug console (#122, #204).

88 comments:

Anonymous said...

"GM_deleteValue()" This is awesome!

Anonymous said...

It keeps spewing the following:

Greasemonkey getFirebugConsole() error:
(new TypeError("chromeWin.Firebug is undefined", "file:///home/username/.mozilla/firefox/x77a0ubp.default/extensions/%7Be4a8a97b-f2ed-450b-b12d-ee082ba24781%7D/components/greasemonkey.js", 392))

Anonymous said...

"Install failed" that's what it keeps on saying.

Nicu said...

It fails a lot, how can I install the old one

JNudda said...

Any plans to add a toolbar button (instead of just a status bar button)?

آلـ ع ـآشـقـ آلـمـظـلـومـ said...

Please Greasemonkey not work

There is an error in the language file
ar-SA

1- gm-browser.properties

greeting.btnAccess=ت


2- greasemonkey.dtd

ENTITY manage.button.close "أغلاق"

Anonymous said...

Hello

on macos, my syslog gets plenty of:
Feb 20 19:49:34 host [0x0-0x23023].org.mozilla.firefox[0]: Greasemonkey getFirebugConsole() error:
Feb 20 19:49:34 host [0x0-0x23023].org.mozilla.firefox[0]: (new TypeError("chromeWin.Firebug is undefined", "file:///Users/+username+/Library/Application%20Support/Firefox/Profiles/xxxxxxx.default/extensions/%7Be4a8a97b-f2ed-450b-b12d-ee082ba24781%7D/components/greasemonkey.js", 392))

no way to remove this or send them in a dedicated log ?

thanks a lot

Thorpe said...

GM scripts seemed to have stopped working out of the blue on Flickr.com, as of Feb. 14th or 15th. Anyone else complain of this?

TG said...

hi, i'm new to all this. from my tool menu the 'user script command' tab isn't highlighted. could you please advise. thanx

coach anne said...

Trying to install latest version Greasemonkey in Firefox 3.0.6 in Vista. NOTHING happens -- no error messages, no anything. Have tried repeatedly, restarting Firefox each time. Even shut 'puter all the way down. Greasemonkey just doesn't load.

Are there other Firefox extentions which prevent Greasemonkey from loading? If so, which?

Did not find any help with this in the Greasemonkey Users Forum. Any pointers to help would be appreciated.

Anonymous said...

not everything people have a intertnet. Is it possible download greasemonkey to hdd and install later to other computers?

Stéphane said...

Bravissiiiiiiiiimmmmmmmmoooo!!!!!!
Well done,grazie mille,vous êtes super,votre travail mérite que l'on vous donne un peu de € où $ suivant nos moyens,car si vous saviez a quel point votre application m'aide,elle me permet de continuer la création de mon site web,alors a last time>>>
>>>Thank u very xxxxxxx Much to all who have work it on & apologize for my basic english,i try to do my best,day after day i learn,i'm young & french ,i leave in Nice city in the south-east of France.MERCI les amis (es)

Stéphane said...

Bravissiiiiiiiiimmmmmmmmoooo!!!!!!
Well done,grazie mille,vous êtes super,votre travail mérite que l'on vous donne un peu de € où $ suivant nos moyens,car si vous saviez a quel point votre application m'aide,elle me permet de continuer la création de mon site web,alors a last time>>>
>>>Thank u very xxxxxxx Much to all who have work it on & apologize for my basic english,i try to do my best,day after day i learn,i'm young & french ,i leave in Nice city in the south-east of France.MERCI les amis (es)

Anonymous said...

good morning,
i have a problem with installation greasemonkey:

Firefox could not install the file at

https://addons.mozilla.org/en-US/firefox/downloads/latest/748

because: download error
-228



Help please

BeeVee said...

Like Coach Anne, I cannot install Greasemonkey. It was working fine (and I use scripts like Better GMail2, YousableTube Fix, Better Lifehacker, etc.) and since I don't exactly know when it disappeared and I can't reinstall. I am using Vista SP1 Home Premium; Fx 3.0.6; a bunch o' add-ons and I've tried a new profile, removing the extensions.(ini|cache|rdf) files and so on. Worst yet I cannot find anyone online with a similar problem. Please send me a mail or reply here I *hate* seeing rubbish quality YouTube and my spam count in GMail (among others)

bayrakçı said...

thank you so much. this is most useful software. nice :)

acı cehre said...

GM scripts seemed to have stopped working out of the blue on Flickr.com, as of Feb. 14th or 15th. Anyone else complain of this?

elma kapsülü said...

Any plans to add a toolbar button (instead of just a status bar button)?

Anonymous said...

belajar forex

forex

bisnis internet

internet marketing

belajar internet marketing

walet

sarang walet

cd walet

sarang burung walet

rumah walet

mesin walet

best forex robot

best forex robots

forex robots

forex robot

forex signal

forex signals

Efren Leon said...

i disable all my addons in order to know what was making firefox to hang after exit the only way that i make firefox to exit properly was to disable greasemonkey does anybody knows any solution

anthony said...

How can I delete this?

anthony said...

How can I delete this Greasemonkey Release 0.8.20090123.1/ uninstall & get rid of it? Is this typical of greasemonkey grease?

anthony said...

How do I uninstall/delete/get rid of this Greasemonkey Release 0.8.20090123.1? Is this typical greasemonkey grease?

DragonLvr2k5 said...

Greasemonkey won't install properly... Restarted 10x and it says "This add-on will be installed when firefox is restarted...

Anonymous said...

belajar forex

forex

bisnis internet

bisnis di internet

bisnis internet marketing

internet marketing

belajar internet marketing

belajar internet marketing

internet marketing

bisnis internet

bisnis internet marketing

bisnis di internet

best forex robot

best forex robots

forex robots

forex robot

forex signal

forex signals

diet

cara diet

diet sehat

diet alami

langsing

langsing sehat

langsing alami

obat diet

menu makanan diet

tips diet

Anonymous said...

belajar forex

forex

bisnis internet

bisnis di internet

bisnis internet marketing

internet marketing

belajar internet marketing

belajar internet marketing

internet marketing

bisnis internet

bisnis internet marketing

bisnis di internet

best forex robot

best forex robots

forex robots

forex robot

forex signal

forex signals

diet

cara diet

diet sehat

diet alami

langsing

langsing sehat

langsing alami

obat diet

menu makanan diet

tips diet

Anonymous said...

hi this is great... except mine also stopped working. i use it for fallensword game mostly. it was fine, and i was working away, then suddenly it stopped working. the little monkey still smiles (i think he is soooo cool), but thats it. i un installed it, reinstalled it, updated it. i even restored the comp to before i had greasemonkey, but nothing. before restore i could not write or paste scripts, and it would not recognise whick page i was on. i am on vista sp1 also. please help i miss my monkey soooo much, i lonely

Anonymous said...

Could we please get a version that works with 3.5b4pre ? 3.1 got renamed...

Dereck said...

I remember GM back in old days getting full RS speed.

Peter said...

Releasing Firefox 3.1 add on so fast is really great. I hope we can have great benefit of it.

Scott G said...

Hello, the "User Script Commands" menu is grayed out and I cannot select it (I am using FF 3.0.8.).

Please post a message here when this is resolved.

Anonymous said...

thanks for this awesome software.. anyways i needed your help .. i need something similar for Internet explorer .. please help

Anonymous said...

thanks for this awesome software.. anyways i needed your help .. i need something similar for Internet explorer .. please help

Anonymous said...

great add on.i want to add source scripts to greasemonkey but i don't know how to do it exactly.i try copying source script to notepad then saving as script then drag the saved file to greasemonkey window but nothing hapen.still must be a way to use script in this form not only to download directly from web page.i need to do so because i decide to uninstall greasemonkey and reinstall but doing this will cause to lose those scripts from first install and i don't want to search again on the net to exact web page. thx!

Carl said...

The scripts I have installed keep disappearing in the GM icon right click menu. Of the three I have installed, only two at most are displayed. It is now only showing one script. In the manage scripts all three show and are enabled but only one script is showing in the right click menu. I think this has only started to occur after installing FF 3.0.9.

Anonymous said...

please update greasemonkey that it can be used in firefox 3.5 beta 4

sumit goyal said...

waiting eagerly firefox 3.5 beta 4 compliant build.
thanks a lot in advance.

aatkco said...

puplic arabic version proplem :
كيان غير معرف
خطا فى اعراب xml

please follow us @ the ticket :
http://greasemonkey.devjavu.com/ticket/257#preview

thanks

peaceman said...

pls update it doesn't work with 3.5b4

Brent said...

Update for the new version of Firefox!!! These Facebook quizzes are KILLING ME. Pretty please?!?!

Mango said...

One of the best addons ever. I'm using it for ages.

AndrewDBarker said...

Firefox 3.5 Beta 4 is out, doesn't like Greasemonkey anymore. D:

Just thought you should know.

Anonymous said...

GMonkey works great with Firefox 3.5b4, at least my scripts do - just download the xpi file and edit the max version number in install.rdf inside the .xpi file...

SO, dear developers, could you please make these little changes and publish the update for your great addon?

Mhelan's Tristan said...

update greasemonkey for firefox 3.5 beta 4 pls!!!

cometa said...

Одно из лучших расширений для Огнелиса. Спасибо.

curious said...

Firefox 3.5b4 released. Looking forward to a compat version :D

Anonymous said...

I keep getting a message that this addon is not compatible with Firefox/3.0.10......Can someone tell me if I'm doing something wrong or is it not compatible as of yet?

Thank you!

sumit said...

Quote: GMonkey works great with Firefox 3.5b4, at least my scripts do - just download the xpi file and edit the max version number in install.rdf inside the .xpi file...

SO, dear developers, could you please make these little changes and publish the update for your great addon?

04 May, 2009 01:49
thanks dude, i was able to install greasemonkey this way

Anthony said...

I like the concept of being able to switch directly between email accounts. I like the Concept...unfortunately the 'product' wastes a lot of time. Word salad "comment/helps" confuse the situation, provide nothing but add to the frustration overload. To fix it, make it useful AND stable is what's required, all the rest of this is BS that fucks up my computer, wastes my time, and is now going delete. When you have it up and running..that's what I'll see
until then...great program, just get it together...

asiafxonline said...

No.1 Akademi Internet MarketingCara Mudah Belajar Bisnis OnlinePersonal Online Business SystemBelajar Forex TradingSistem Forex TradingBroker Forex IndonesiaBuku Forex GratisSignal ForexBelajar Investasi KomoditiBerita Ekonomi TerkiniBelajar Investasi Index SahamHarga Index Saham Gabungan

asiafxonline said...

No.1 Akademi Internet Marketing
Cara Mudah Belajar Bisnis Online
Personal Online Business System
Belajar Forex Trading
Sistem Forex Trading
Broker Forex Indonesia
Buku Forex Gratis
Signal Forex
Belajar Investasi Komoditi
Berita Ekonomi Terkini
Belajar Investasi Index Saham
Harga Index Saham Gabungan

Anonymous said...

Please update "Greasemonkey" !! I'm using firefox 3.5b4..

Anonymous said...

Are you guys ever going to update your plugin so it can be used with Firefox 3.5? Or should we assume it has been abandoned?

INFOHOMEINDUSTRIES said...

awesome ,..
awesome ,..
awesome ,..
awesome ,..
awesome ,..
viva scripting

Anonymous said...

"about:config", then search for "extensions.checkcompatibilty" and set it to "false"

saua said...

To all those nagging for the 3.5b4 version: you're using a beta version. Don't expect everyone to go running for help, you've asked to be on your own by using a beta.

Editing the max_version of the .xpi file works like a charm and isn't too much work for anyone who's using beta software, so stop nagging and start enjoying Greasemonkey.

Anonymous said...

try it:

http://morgoth-melkor.mybrute.com

F-3000 said...

Still getting this constantly.

Greasemonkey getFirebugConsole() error:
(new TypeError("chromeWin.Firebug is undefined", "file:///Users/f3000/Library/Application%20Support/Firefox/Profiles/********.default/extensions/%7Be4a8a97b-f2ed-450b-b12d-ee082ba24781%7D/components/greasemonkey.js", 392))

John said...

This was one of my first add-ons, when I started in this webmaster venture.

Anonymous said...

When I right click the GM icon sometimes my scripts show and other times it says no scripts installed even though I have 6 installed scripts and 4 enabled.

They show in the Manage user scripts but not in the right click menu.

Anonymous said...

I can't install it. I get this error on firefox 3.0.11:

Firefox could not install the file at

https://addons.mozilla.org/en-US/firefox/downloads/latest/748/addon-748-latest.xpi

because: Unexpected installation error
Review the Error Console log for more details.
-203

Gloria Chang said...

Is this version compatible with Firefox 3.5? Mine turned out to be not compatible after FF3.5 was installed.

Anonymous said...

use nightly tester tools
https://addons.mozilla.org/en-US/firefox/addon/6543

huy32hh said...

pultur

Rangan Kasturi said...

Well, if it doesn't work with 3.5 Firefox, then follow the steps below:

- Download the xpi by right-clcking on the link and selecting "Save as" on your Desktop or to a folder location
- Rename the file from .xpi to .zip
- Locate the file "install.rdf" inside the zip file, open it in Notepad and search for the following text under Firefox:


-- Firefox --
em:targetApplication
Description
em:id{ec8030f7-c20a-464f-9b0e-13a3a9e97384}em:id
em:minVersion .5 em:minVersion
em:maxVersion 3.5.* em:maxVersion
-->

- In the above text, change the max-version to 3.5.* (It would probably show 3.1b2)
- Save the file in Notepad and close Notepad
- Save the archive/zip file
- Rename the file from .zip to .xpi
- Go to firefox, select "Add-ons" from "Tools" menu
- Press the Windows-key + D (show desktop shortcut) or go to the folder where you had downloaded the .xpi file
- Drag drop the .xpi file on to the task bar on top of the firefox add-on window
- Install and restart Firefox
- Enjoy!

Anonymous said...

or use winrar instead to open the .xpi directly. you can update the install.rdf within the archive. thats much faster.

Mike said...

I am having a bit of a problem with this release since upgrading to Firefox 3.5. It causes Firefox to completely lock up when I try to play a particular browser based game (Ikariam.com). If I disable GreaseMonkey I can get into the game just fine. Prior to disabling GreaseMonkey I had been disabling scripts one by one to see if there was an offending script causing the problem. Unfortunately, the only thing that rectified things was shutting down GreaseMonkey.

bruce_santarosa said...

Last week I installed greasemonkey as part of a plan to backup Google docs. My computer slowed down and got slower and slower. I scanned it with 3 different tools and didn't find anything remarkable. I uninstalled GM and immediately I was OK. Re-installed and the problem began again. I have an old P4 but lots of memory. XP Home fully patched. Anyone else have this problem.?

Marcin Juszkiewicz said...

Each time when I reboot Firefox 3.5 Greasemonkey forgets all scripts I installed for it :(

indogear said...

Thanks....
Home Full Download, Home Crack Serial, Home Rapidshare links, Home Warez Download, Home Free Full Download, Home Torrent CDKey, Home Nocd Patch

Direct links, rapidshare links, easy-share links,… download full softwares, portable appz, games, ebooks, movies, music,script,…and MORE… http//indogear.com

JumpinJack said...

When my Firefox autoupdated to 3.0.1 I noticed a problem with flickr.com.

Namely, I couldn't edit description under my photos anymore. Photo description should change into an edit box, when clicked, but it doesn't.

I upgraded my Firefox to the newest version (3.5.1) and it was exactly the same.

Then I noticed, everything works again when I disable Greasemonkey. So there's obviously some compatibility issue with new version of Firefox.

Please check this out!

JumpinJack said...

Update:

The problem with disabling photo descriptions occurs only with some greasemonkey scripts (e.g. with www.rhyley.org/gm/flickrRichEdit.user.js )

Anonymous said...

Does not work with firefox 3.5.1 anymore. U goin to fix that?

aziz_0 said...
This comment has been removed by the author.
aziz_0 said...

I have problem

when I install the Greasemonkey Release 0.8.20090123.1 on Firefox 3.5.1 he side
you must resrt the Firefox
this is photo of the problem :
http://www.l44l.com/upfiles9/VL106197.jpg

but After that the Greasemonkey disappear
this is photo of the problem :
http://www.l44l.com/upfiles9/CuU06280.jpg

how can I install it ???

Anonymous said...

Whenever I try and install a script, I get the following error:

Script could not be installed [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.open]" nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)" location: "JS frame :: chrome://greasemonkey/content/utils.js :: getContents :: line 244" data: no]



FF 3.5.1 + GM 0.8.20090123.1

What's up with that? Please help me!

viv energy drink said...

i un installed it, reinstalled it, updated it. i even restored the comp to before i had greasemonkey, but nothing. before restore i could not write or paste scripts, and it would not recognise whick page i was on.

Anonymous said...

Doesnt work with my Firefox 3.5.2 :(((
I really need Greasemonkey for my MeinVZ.net

Anonymous said...

Greasemonkey 0.8.20090123.1 kan inte installeras eftersom det inte är kompatibelt med Firefox 3.5.2.

It needs an update cant install on latest Firefox 3.5.2 because its not compitable :(

Anonymous said...

omg noobs

Anonymous said...

Ooops... What a pitty, Greasymonkey does not work with Firefox 3.5.2 anymore. I hope there will be an update sooner or later as I'm using this add on for some special scripts which I love very much... Thank you in advance...

Anonymous said...

it dont work!
caus my version is to new. how long to w8 to get the new version?

Anonymous said...

omfg, stupid noobs

Feller said...

Yes this is plugin that almost everybody knows. In such case, it must be worth it. Cheeers

Bisnis Online said...

this is great, i will try use it...

viv energy drink said...

Tried to install 3 times, but nothing. Experiencing some strange problems and nothing moves on. I'll try to sit on the code to figure out what is going on. Hope my knowledge will be useful :)

online video izle said...

okey oyna okey oyna kolay gelsin
klip izle müzik dinle
film izle film hoşgeldiniz
tatil tatil seni bekliyor
tatili turk ve avrupa tatili
oyunlar oyunlar burda
dövüş oyunlar turkey dovus
film izle film diyari
online video izle film izle
ruya tabiri islami ruya
giyim giyin sende
erkek giyim erkeklere gore
gomlek suit shirt
takım elbise suit men

vineel said...

Please tell me step by step hw to download and how to upload the theme.Really got Fedup with old theme